
JOSM untuk Perhitungan Kualitas Data

Tujuan Pembelajaran:

• Memahami cara memilih dan menghitung jumlah objek dalam suatu batas administrasi
• Mengetahui cara menghitung jumlah error dan warning dalam suatu batas administrasi
• Mengetahui cara melakukan validasi batas-batas administrasi

Dalam melakukan kegiatan pemetaan salah satu targetnya adalah menghasilkan peta yang berkual-
itas. Salah satu kualitas yang dimaksud berupa kelengkapan jumlah data dan informasi yang diper-
oleh dalam kegiatan pengumpulan data di lapangan. Pemanfaatan OpenStreetMap sebagai peta dasar
yang digunakan untuk menampilkan hasil pengumpulan data di lapangan dapat membantu Anda dalam
melakukan perhitungan baik dari banyaknya data objek yang ada kumpulkan dan juga informasi yang
terdapat di dalamnya. Pada modul ini Anda akan mempelajari menghitung jumlah data infrastruktur dan
batas-batas administrasi hasil pengumpulan di lapangan dengan menggunakan perangkat lunak Java
OpenStreetMap (JOSM)

I. Menghitung Objek Dalam Batas Administrasi

Salah satu kegiatan pada tahap memantau kualitas data adalah dengan menghitung jumlah objek yang
berada di wilayah pemetaan. Tujuannya adalah untuk mengetahui pertambahan data yang ada di
wilayah pemetaan sebelum dan sesudah kegiatan pemetaan dilaksanakan. Selain itu, kegiatan ini
bertujuan untuk memantau kelengkapan atribut dan bentuk masing-masing objek yang menjadi prior-
itas di wilayah tersebut. Anda dapat menggunakan JOSM dalam melakukan perhitungan objek dalam
area pemetaan. Terdapat beberapa langkah untuk menghitung objek dalam suatu wilayah administrasi
misalnya pada tingkat kelurahan.

a. Download Data OpenStreetMap di Wilayah Pemetaan

Sebelum Anda memulai menghitung jumlah objek, tentu saja Anda harus men-download data Open-
StreetMap di area pemetaan. Dalam melakukan perhitungan objek, Anda dapat menggunakan batas
administrasi kelurahan yang terdapat di dalam wilayah kecamatan . Sebagai contoh, Anda akanmenghi-
tung jumlah objek di Kelurahan Pleburan, Kecamatan Semarang Selatan. Berikut adalah langkah-
langkah yang dilakukan saat men-download data OpenStreetMap:

• Buka JOSM di laptop/komputer Anda.
• Kemudian pilih menu File → Download Data ,nda akan melihat kotak area yang dapat Anda
download di OpenStreetMap.

• Pilih menu Areas around Places kemudian masukkan nama kecamatan “Pleburan” di kotak pen-
carian dan pastikan Anda telahmencentang tipe dataOpenStreetMap Data dan pilihanDownload
as New Layer.

• Setelah berhasil, pilih hasil pencarian yang paling sesuai dengan kecamatan yang ingin Anda
download. Pilihlah yang berada di Semarang dan memiliki tipe boundary=administrative. Hasil
pencarian yang anda pilih akan berwarna biru.
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“Kotak pencarian area download di JOSM”

Kotak pencarian area download di JOSM

• Setelah semua selesai diatur, kemudian klik Download.

“Hasil download data di JOSM”

Hasil download data di JOSM

Catatan : Jika wilayah kecamatan Anda terlalu besar, silakan download secara bertahap
sampai semua area berhasil di-download ke dalam JOSM

b. Menghitung Jumlah Objek di Suatu Wilayah Administrasi

Jika Anda telah berhasil mendownload data di area pemetaan , maka langkah berikutnya adalah
melakukan perhitungan jumlah objek di kelurahan yang telah ditentukan. Berikut adalah langkah-
langkah dalam melakukan perhitungan jumlah objek:

• Pilih Edit → Search untuk memilih batas area administrasi Kelurahan Pleburan.
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“Menu pencarian data di JOSM”

Menu pencarian data di JOSM

• Kemudian di kotak pencarian silahkan ketik “admin_level=7” kemudian klik Start Search

“Jendela pencarian untuk memilih kelurahan di JOSM”

Jendela pencarian untuk memilih kelurahan di JOSM

• Anda akan melihat semua obyek OSM yang memiliki _tag “admin_level=7_” akan terpilih di jen-
dela selection. Setelah itu silakan pilih Kelurahan Pleburan yang akan Anda hitung objek yang
ada di dalam wilayah tersebut dan klik 2 kali. Anda akan melihat garis batas administrasi Kelura-
han Pleburan akan berubah menjadi warna ungu di dalam layer data JOSM, hal ini menandakan
kelurahan tersebut sudah terpilih.
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“Hasil pencarian kelurahan di JOSM”

Hasil pencarian kelurahan di JOSM

• Jika di JOSM Anda belum terdapat menu Selectionmaka Anda harus menginstal plugin utilsplugin
di JOSM. Penjelasan tentang cara menginstal plugin ini dapat Anda lihat di ModulMenambahkan
Data OSM menggunakan JOSM. Setelah itu pilih menu Selection → All inside [testing]. Anda
akan melihat seluruh data yang berada di Kelurahan Pleburan akan terpilih dan berwarna merah.

“Hasil seleksi data di JOSM”

Hasil seleksi data di JOSM

• Kemudian pilih kembali menu Selection → Intersecting Ways untuk memilih kembali semua data
yang di dalam maupun yang bersinggungan dengan Kelurahan Pleburan, seperti jaringan jalan
dan sungai. Durasi dari proses ini berlangsung tergantung dari luas wilayah dan banyaknya data
yang ada di dalamnya.
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“Seleksi keseluruhan data di area tertentu di JOSM”

Seleksi keseluruhan data di area tertentu di JOSM

• Setelah selesai Anda dapat melihat total jumlah objek di jendela properties/membership pada
JOSM Anda.

“Seleksi keseluruhan data di area tertentu di JOSM”

Seleksi keseluruhan data di area tertentu di JOSM

• Seperti yang terlihat di Kelurahan Pleburan, total data yang ada di wilayah tersebut sebesar 1995
objek. Namun perlu Anda ingat, ini hanyalah total data keseluruhan diOpenStreetMap yang men-
jadi rangkaian untuk menghitung kualitas data di JOSM, Anda tidak akan melakukan perhitungan

5



untuk masing-masing spesifik objek.

II. Menghitung Jumlah Error danWarning Dalam Batas Administrasi

Setelah berhasil menghitung total data dalam area pemetaan atau dalam contoh ini adalah Kelurahan
Pleburan, Anda akan melanjutkan langkah-langkah untuk menghitung jumlah Error danWarning dalam
data yang telah Anda pilih di Kelurahan Pleburan. Berikut adalah langkah-langkah yang dapat dilakukan:

• Klik tombol Validation pada jendela validasi di JOSM. Kemudian tunggu hingga JOSM selesai
menghitung jumlah Error danWarning yang ada di data Anda.

“Jendela validasi data di JOSM”

Jendela validasi data di JOSM

• Jika JOSM sudah selesai menghitung, maka akan muncul daftar error dan warning pada data
tersebut. Anda sebaiknya mencatat jumlah error dan warning yang terdapat pada jendela validasi
serta langsungmemperbaiki dan menyelesaikan semua warning dan error. Untuk penjelasan lebih
lanjut tentang cara memperbaiki (validasi) data di JOSM serta daftar error danwarning yang sering
terjadi dapat anda lihat pada Modul Penggunaan JOSM untuk Validasi Data Survei.
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“Hasil validasi data di JOSM”

Hasil validasi data di JOSM

• Setelah memperbaiki error danwarning yang ada, Anda dapat melakukan rekapitulasi perhitungan
kualitas data diMicrosoft Excel atau Google Sheet. Hal ini bertujuan untuk melihat perbandingan
kualitas data yang ada di kelurahan pemetaan, sebelum dan sesudah kegiatan pengumpulan data
di lapangan, sehingga Anda dapat melihat progres dari kegiatan pemetaan tidak hanya dari sisi
kuantitas tapi juga dari kualitas data yang dihasilkan. Jenis error dan Warning yang dihasilkan
juga dimasukkan ke dalam tabel perhitungan.

Tabel Rekapitulasi Perhitungan Kualitas Data

“Tabel Rekapitulasi Perhitungan Data”

Seperti yang dapat Anda lihat pada tabel di atas, jumlah objek di Kelurahan Pleburan sebelum
pemetaan adalah 1.863 dimana terdapat 4 warning pada data yang ada. Kemudian setelah di-
lakukan kegiatan pengumpulan data di lapangan dan validasi data jumlah data yang ada di kelurahan
tersebut meningkat menjadi 1.963 dimana tidak terdapat error maupun warning sama sekali. Anda
dapat melihat contoh tabel hasil perhitungan kualitas data di Kota Semarang secara keseluruhan di
http://bit.ly/tabeldatasemarang

III. Melakukan Validasi Batas-Batas Administrasi

Setelah Andamelakukan rekapitulasi atau perhitungan jumlah objek dan kualitas data OSM di kelurahan
pemetaan, hal yang tidak kalah penting untuk dilakukan adalah melakukan perhitungan untuk kualitas
data terhadap batas-batas administrasi. Dalam perhitungan ini, Anda akan melakukan validasi terhadap
batas-batas kelurahan dan rukun warga (RW) yang terdapat di kelurahan tersebut. Adapun validasi
yang dilakukan adalah meliputi jumlah RW yang dipetakan, kelengkapan informasi (tag), relasi dari
batas kelurahan dan RW, dan melakukan backup batas administrasi dengan menyimpannya sebagai
file .osm yang baru. Kita kembali akan menggunakan Kelurahan Pleburan yang telah kita download
pada materi sebelumnya.

a. Menghitung Jumlah RW
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Berikut adalah langkah-langkah yang harus Anda lakukan dalam menghitung jumlah RW:

• Anda telah memiliki data OpenStreetMap Kelurahan Pleburan. Namun, data yang Anda miliki
adalah data keseluruhan dimana memiliki berbagai macam objek di dalamnya sehingga bisa
menyulitkan Anda untuk melihat batas-batas administrasi di wilayah tersebut. Untuk itu, Anda
dapat melakukan filter data di JOSM. Jika Anda belum mengetahui fungsi alat filter dan cara peng-
gunaanya dengan lebih lanjut silahkan melihat Modul Menggunakan Alat Filter di JOSM.

• Aktifkan alat filter di JOSM dengan cara klik menuWindows → Filter

“Langkah untuk melakukan filter data OpenStreetMap di JOSM”

Langkah untuk melakukan filter data OpenStreetMap di JOSM

• Jendela filter akan muncul di JOSM Anda. Kemudian silakan klik add dan masukkan query untuk
menyaring data sehingga yang akan ditampilkan di JOSM hanya batas-batas administrasi saja.
Query tersebut adalah “is_in:village”=”Pleburan”.

• Anda akan melihat tampilan data di JOSM anda akan berubah seperti berikut:
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“Tampilan hasil filter data untuk batas-batas administrasi di JOSM”

Tampilan hasil filter data untuk batas-batas administrasi di JOSM

• Kemudian pilih seluruh batas RW yang ada di Kelurahan Pleburan dengan cara menggunakan alat
search. Klik menu Edit → Search. Anda kemudian akan melihat jendela pencarian. Kemudian
masukkan query “admin_level=9” dan klik Start Search.

“Query untuk pencarian batas-batas RW di JOSM”

Query untuk pencarian batas-batas RW di JOSM

• Anda akan melihat batas RW di data yang terpilih. Hal ini ditunjukkan dengan garis-garis batas
administrasi menjadi warna ungu. Kemudian di bagian jendela selection Anda akan melihat daftar
RW yang ada di data Kelurahan Pleburan.
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“Hasil seleksi untuk batas-batas RW di Kelurahan Pleburan”

Hasil seleksi untuk batas-batas RW di Kelurahan Pleburan

• Anda dapat membandingkan jumlah RW yang ada di Kelurahan Pleburan yang merupakan hasil
selection di JOSM dengan tabel rekapitulasi hasil pengumpulan data di lapangan.

“Contoh tabel rekapitulasi jumlah RW di kelurahan
pemetaan”

Contoh tabel rekapitulasi jumlah RW di kelurahan pemetaan

Anda dapat melihat pada tabel di atas bahwa jumlah RW yang ada di Kelurahan Pleburan sebanyak 6
RW dan pada gambar hasil seleksi batas RW di JOSM juga terlihat terdapat 6 RW yang terpilih mulai
dari RW 01 hingga RW 06. Dengan begitu telah terdapat kesamaan data dan Anda dapat memvalidasi
jumlah RW di Kelurahan Pleburan yang ada di OpenStreetMap.

b. Menghitung Kelengkapan Tag dan Relasi Batas-Batas Administrasi

Setelah menghitung jumlah RW di Kelurahan Pleburan, sekarang Anda perlu untuk menghitung ke-
lengkapan informasi (tag) yang harus dimiliki oleh batas RW tersebut. Berikut adalah informasi (tag)
untuk batas-batas administrasi RW:

Tabel Tag Batas Administrasi Rukun Warga (RW)
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key possible values

type boundary
boundary administrative
name (nama RW)
admin_level 9
is_in:province (nama provinsi)
is_in:city (Kota) / is_in:town (Kabupaten) (nama kota/kabupaten)
is_in:municipality (nama kecamatan)
is_in:village (nama kelurahan)
is_in:RW (nama rw)
flood_prone *khusus untuk relasi RW yes (Iya), no (Tidak)
landslide_prone *khusus untuk relasi RW yes (Iya), no (Tidak)
source HOT_InAWARESurvey_2018 (Disesuaikan dengan kegiatan pemetaan)

Untuk melakukan validasi _tag _batas-batas RW, Anda dapat mengikuti langkah-langkah sebagai
berikut:

• Pilih semua daftar RW pada jendela selection hasil dari fitur search di JOSM.

“Memilih daftar RW yang ada di Kelurahan Pleburan”

Memilih daftar RW yang ada di Kelurahan Pleburan

• klik kanan pada daftar RW kemudian pilih Edit. Anda kemudian akan melihat kotak peringatan
bahwa Anda akanmembuka seluruh informasi untuk masing-masing batas RW dimana untuk Kelu-
rahan Pleburan akan terbuka sebanyak 6 jendela informasi. Silahkan klik Ok.
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“Langkah melihat informasi batas batas RW”

Langkah melihat informasi batas-batas RW

• Setelah jendela terbuka silahkan Anda periksa kelengkapan informasi (tag) untukmasing-masing
batas RW. Selain itu, periksa hubungan relasi dengan antar batas-batas RW lain dengan melihat
alur relasi di bagian member. Relasi yang baik adalah jika hubungan antara member batas RW
saling terhubung danmembentuk loop atau lingkaran yang terhubung. Jika Anda ingin mengetahui
hubungan antar relasi dan cara melakukan input batas-batas administrasi di JOSM dengan lebih
lengkap, maka Anda dapat melihat Modul Membuat Batas Administrasi di JOSM.

Kotak relasi dan informasi batas administrasi di JOSM

Anda dapat menambahkan tag jika di RW tersebut belum sesuai dengan model data yang telah di-
tentukan dan memperbaiki bentuk relasi dengan mengatur urutan member dan rules masing-masing
member.

Catatan : Jika terdapat kekurangan atau kelebihan jumlah RW, maka Anda perlu
mendiskusikan masalah ini dengan Data Entry yang melakukan pengumpulan data
dan Quality Assurance yang melakukan input batas-batas administrasi ke dalam Open-
StreetMap. Lakukan langkah-langkah pengecekan yang sama terhadap relasi batas
administrasi kelurahan (“admin_level=7”) dan kecamatan (“admin_level=6”)

c. Melakukan Backup Batas Administrasi
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Setelah melakukan perhitungan dan validasi untuk batas-batas administrasi, Anda perlu untuk
melakukan backup batas administrasi. Hal ini dilakukan agar Anda dapat memiliki cadangan batas
administrasi wilayah pemetaan jika terjadi sesuatu yang tidak diinginkan seperti batas administrasi
tersebut hilang atau ada pengguna lain yang mengubahnya secara tidak tepat. Untuk melakukan hal
tersebut Anda dapat mengikuti langkah-langkah berikut ini:

• Silahkan klik menu Edit → Copy

“Menyalin data batas administrasi di JOSM”

Menyalin data batas administrasi di JOSM

• Kemudian pilih File → New Layer. Anda akan melihat layer baru pada JOSM.
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“Membuat layer baru
pada JOSM”

Membuat layer baru pada JOSM

• Kemudian klik Edit → Paste at source position
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“Menyalin batas administrasi pada Layer baru pada JOSM”

Menyalin batas administrasi pada Layer baru pada JOSM

• Anda akan memiliki layer baru yang hanya berupa data batas-batas administrasi saja. Kemudian
klik menu File → Save dan simpan data tersebut ke dalam format file .osm dan berikan nama
sesuai dengan kelurahan yang Anda petakan.
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“Menyimpan layer batas administrasi di JOSM”

Menyimpan layer batas administrasi di JOSM

RINGKASAN

Anda telah mempelajari cara untuk melakukan perhitungan kualitas data di JOSM. Materi ini merupakan
salah satu dari kegiatan rekapitulasi sekaligus validasi dari data yang telah dimasukkan ke dalam Open-
StreetMap setelah melakukan pengumpulan data di lapangan oleh Data Entry dan telah divalidasi oleh
Quality Assurance. Dengan melakukan perhitungan kualitas data yang telah divalidasi oleh Quality As-
surance, akan menghasilkan kualitas data yang semakin baik. Berikut adalah beberapa hal yang telah
Anda pelajari dalam modul ini:

• Menghitung jumlah objek dalam batas administrasi kelurahan tertentu
• Menghitung error dan warning dalam batas administrasi kelurahan tertentu
• Melakukan rekapitulasi perbandingan jumlah data dan jumlah error / warning
• Melakukan validasi batas administrasi meliputi menghitung jumlah RW, mengecek kelengkapan
informasi (tag) dan relasi antara batas-batas administrasi

• Melakukan backup data administrasi dalam file .osm
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